{
  lib,
  pkgs,
  modulesPath,
  ...
}: {
  imports = [
    (modulesPath + "/installer/scan/not-detected.nix")
  ];

  hardware.cpu.amd.updateMicrocode = true; # Why not?
  hardware.cpu.intel.updateMicrocode = true; # Why not?

  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";

  soispha.disks = {
    enable = false;
  };

  boot = {
    kernelModules = [];
    kernelPackages = lib.mkDefault pkgs.linuxPackages_6_1; # use this kernel, as it's supported by zfs
  };
}