{
  self,
  system,
  ...
}: {
  install = {
    type = "app";
    program = "${self.packages."${system}".install}/bin/install";
  };
  activate = {
    type = "app";
    program = "${self.packages."${system}".activate}/bin/activate";
  };
  setup = {
    type = "app";
    program = "${self.packages."${system}".setup}/bin/setup";
  };
  config_setup = {
    type = "app";
    program = "${self.packages."${system}".config_setup}/bin/config_setup";
  };
  default = self.apps."${system}".activate;
}