about summary refs log tree commit diff stats
path: root/tests/infrastructure/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/infrastructure/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/infrastructure/default.nix b/tests/infrastructure/default.nix
index 64a6ad01..0e0408e7 100644
--- a/tests/infrastructure/default.nix
+++ b/tests/infrastructure/default.nix
@@ -4,6 +4,7 @@
   lib,
   nixos-lib,
   extraModules,
+  sysLib,
   ...
 }: {
   name,
@@ -19,7 +20,7 @@ nixos-lib.runTest {
 
   node = {
     specialArgs = {
-      inherit myPkgs;
+      inherit myPkgs sysLib;
     };
     # Use the nixpkgs as constructed by the `nixpkgs.*` options
     pkgs = null;
@@ -82,7 +83,7 @@ nixos-lib.runTest {
       ''}")
 
       machine.succeed("sudo -u soispha ${pkgs.writeShellScript "mkGoldenRecord" ''
-        set -ex
+        set -e
 
         # HACK: Prevent zsh from complaining about missing configuration.
         # TODO: These tests should probably just run under bash. <2024-11-22>