about summary refs log tree commit diff stats
path: root/tests/by-name/nv/nvim-neorg/test.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/by-name/nv/nvim-neorg/test.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/tests/by-name/nv/nvim-neorg/test.nix b/tests/by-name/nv/nvim-neorg/test.nix
new file mode 100644
index 00000000..ee0e1b52
--- /dev/null
+++ b/tests/by-name/nv/nvim-neorg/test.nix
@@ -0,0 +1,46 @@
+{
+  mkTest,
+  extraModules,
+  pkgs,
+  ...
+}:
+mkTest {
+  name = "nvim-neorg";
+
+  configuration = {
+    imports = [
+      ../../../../modules/by-name/nv/nvim/module.nix
+      ../../../../modules/by-name/ni/nixpkgs/module.nix
+    ];
+    config = {
+      soispha = {
+        nixpkgs = {
+          enable = true;
+          systemName = "x86_64-linux";
+        };
+        programs.nvim = {
+          enable = true;
+          shell = pkgs.zsh;
+        };
+      };
+      home-manager.users.soispha = {
+        imports = [
+          extraModules.nixvim.homeManagerModule
+        ];
+      };
+    };
+  };
+
+  alternateScreen = false;
+
+  testData = {
+    "/home/soispha/repos/notes/general/index.norg" = ./data/index.norg;
+    "/home/soispha/repos/notes/general/reference.norg" = ./data/reference.norg;
+  };
+
+  description = ./test.desc;
+
+  # The golden file is just full of nvim's terminal control sequences. There is no point
+  # in trying to check it.
+  hash = null;
+}