about summary refs log tree commit diff stats
path: root/system/users/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--system/users/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/system/users/default.nix b/system/users/default.nix
index d5b69814..adff5df3 100644
--- a/system/users/default.nix
+++ b/system/users/default.nix
@@ -25,8 +25,14 @@ in {
         createHome = true;
         shell = pkgs.zsh;
         initialHashedPassword = cfg.hashedPassword;
-        extraGroups = ["wheel"];
+        extraGroups = [
+          "wheel"
+          "networkmanager" # if I activate network-manager, this will help
+        ];
         uid = 1000;
+        openssh.authorizedKeys.keys = [
+          "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGBFuTNNn71Rhfnop2cdz3r/RhWWlCePnSBOhTBbu2ME soispha"
+        ];
       };
     };
     #    system.activationScripts.home_permissions =