about summary refs log tree commit diff stats
path: root/system/services/steam/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/steam/default.nix')
-rw-r--r--system/services/steam/default.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/system/services/steam/default.nix b/system/services/steam/default.nix
index 2efa54e2..d4c4be63 100644
--- a/system/services/steam/default.nix
+++ b/system/services/steam/default.nix
@@ -1,6 +1,20 @@
 # vim: ts=2
-{lib, ...}: {
-  programs.steam = {
-    enable = true;
+{
+  lib,
+  config,
+  ...
+}: let
+  cfg = config.soispha.services.steam;
+in {
+  options.soispha.services.steam = {
+    enable = lib.mkOption {
+      default = true;
+      description = lib.mdDoc "Enable Steam";
+    };
+  };
+  config = lib.mkIf cfg.enable {
+    programs.steam = {
+      enable = true;
+    };
   };
 }