about summary refs log tree commit diff stats
path: root/system/services/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/services/nix/default.nix')
-rw-r--r--system/services/nix/default.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/system/services/nix/default.nix b/system/services/nix/default.nix
deleted file mode 100644
index 97b7220d..00000000
--- a/system/services/nix/default.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{
-  pkgs,
-  nixpkgs_as_input,
-  templates,
-  ...
-}: let
-  nixpkgs = nixpkgs_as_input;
-in {
-  nix = {
-    package = pkgs.nixStable;
-
-    registry = {
-      nixpkgs.flake = nixpkgs;
-      n.flake = nixpkgs;
-      t.flake = templates;
-    };
-
-    gc = {
-      automatic = true;
-      dates = "weekly";
-      options = "--delete-older-than 7d";
-    };
-    settings = {
-      auto-optimise-store = true;
-      experimental-features = [
-        "nix-command"
-        "flakes"
-        #"ca-derivations"
-      ];
-
-      #substituters = ["https://cache.ngi0.nixos.org/"];
-      #trusted-public-keys = ["cache.ngi0.nixos.org-1:KqH5CBLNSyX184S9BKZJo1LxrxJ9ltnY2uAs5c/f1MA="];
-      fallback = true; # TODO: what does this do?
-
-      keep-failed = true; # keep failed tmp build dirs
-      pure-eval = true; # restrict file system and network access to hash
-    };
-  };
-}