about summary refs log tree commit diff stats
path: root/system/power/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/power/default.nix')
-rw-r--r--system/power/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/power/default.nix b/system/power/default.nix
new file mode 100644
index 00000000..d20a97f2
--- /dev/null
+++ b/system/power/default.nix
@@ -0,0 +1,19 @@
+{...}: {
+  # see this for reference: https://github.com/NixOS/nixpkgs/issues/211345
+  services = {
+    # conflicts with tlp
+    power-profiles-daemon.enable = false;
+    thermald.enable = true;
+    tlp = {
+      enable = true;
+      settings = {
+        CPU_BOOST_ON_AC = 1;
+        CPU_BOOST_ON_BAT = 0;
+        CPU_SCALING_GOVERNOR_ON_AC = "performance";
+        CPU_SCALING_GOVERNOR_ON_BAT = "powersave";
+        SATA_LINKPWR_ON_AC = "max_performance";
+        SATA_LINKPWR_ON_BAT = "min_power";
+      };
+    };
+  };
+}