about summary refs log tree commit diff stats
path: root/system/options/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/options/default.nix')
-rw-r--r--system/options/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/system/options/default.nix b/system/options/default.nix
index 13861199..72ebc4fb 100644
--- a/system/options/default.nix
+++ b/system/options/default.nix
@@ -14,5 +14,13 @@ in {
         description = lib.mdDoc "Which backlight to query for the screen brightness";
       };
     };
+    secrets = {
+      #enable = lib.mkEnableOption "Secrets through agenix";
+      enable = lib.mkOption {
+        type = lib.types.bool;
+        default = true;
+        description = lib.mdDoc "Enable secrets through agenix";
+      };
+    };
   };
 }