about summary refs log tree commit diff stats
path: root/system/filesystemLayouts/filesystemLayouts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/filesystemLayouts/filesystemLayouts.nix')
-rw-r--r--system/filesystemLayouts/filesystemLayouts.nix58
1 files changed, 0 insertions, 58 deletions
diff --git a/system/filesystemLayouts/filesystemLayouts.nix b/system/filesystemLayouts/filesystemLayouts.nix
deleted file mode 100644
index a4215512..00000000
--- a/system/filesystemLayouts/filesystemLayouts.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{
-  config,
-  lib,
-  ...
-}:
-with lib; let
-  cfg = config.system.filesystemLayouts;
-in {
-  options.system.filesystemLayouts = {
-    enable = mkEnableOption (mdDoc "filesysetemLayout");
-    mainDisk = mkOption {
-      type = lib.types.path;
-      example = literalExpression "/dev/disk/by-uuid/0442cb6d-f13a-4635-b487-fa76189774c5";
-      description = lib.mdDoc "Path to the main disk";
-    };
-    efiDisk = mkOption {
-      type = lib.types.path;
-      example = literalExpression "/dev/disk/by-uuid/5143-6136";
-      description = lib.mdDoc "Path to the main disk";
-    };
-  };
-
-  config = mkIf cfg.enable {
-    fileSystems = {
-      "/" = {
-        device = "none";
-        fsType = "tmpfs";
-        options = ["defaults" "size=2G" "mode=755"];
-      };
-      "/nix" = {
-        device = cfg.mainDisk;
-        fsType = "btrfs";
-        options = ["subvol=nix" "compress-force=zstd:15"];
-      };
-      "/srv" = {
-        device = cfg.mainDisk;
-        fsType = "btrfs";
-        options = ["subvol=storage" "compress-force=zstd:15"];
-      };
-      "/boot" = {
-        device = cfg.efiDisk;
-        fsType = "vfat";
-      };
-
-      "/etc/nixos" = {
-        device = "/srv/nix-config";
-        options = ["bind"];
-      };
-
-      "${config.users.soispha.home}/.config" = {
-        device = "none";
-        fsType = "tmpfs";
-        options = ["defaults" "size=1G" "mode=755"];
-      };
-    };
-    swapDevices = [];
-  };
-}