about summary refs log tree commit diff stats
path: root/system/disks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/disks/default.nix')
-rw-r--r--system/disks/default.nix22
1 files changed, 12 insertions, 10 deletions
diff --git a/system/disks/default.nix b/system/disks/default.nix
index 71a43667..28797f2c 100644
--- a/system/disks/default.nix
+++ b/system/disks/default.nix
@@ -108,20 +108,22 @@ in {
       };
     };
     swapDevices = [
-      {
-        device = "/swap/swapfile";
-        priority = 1; # lower than zramSwap, just in case
-        # size = 2048; # TODO can nixos create a btrfs swapfile correctly?
-      }
+      #{
+      #        device = "/swap/swapfile";
+      #        priority = 1; # lower than zramSwap, just in case
+      #        # size = 2048; # TODO can nixos create a btrfs swapfile correctly?
+      #}
     ];
     zramSwap = {
       enable = true;
       priority = 10; # needs to be higher than hardware-swap
     };
-    boot.kernelParams = [
-      "resume=UUID=${cfg.swap.uuid}"
-      "resume_offset=${cfg.swap.resumeOffset}"
-      "zswap.enabled=0" # zswap and zram are not really compatible
-    ];
+    boot = {
+      kernelParams = [
+        "resume_offset=${cfg.swap.resumeOffset}"
+        "zswap.enabled=0" # zswap and zram are not really compatible
+      ];
+      resumeDevice = "/dev/disk/by-uuid/${cfg.swap.uuid}";
+    };
   };
 }