about summary refs log tree commit diff stats
path: root/sys/svcs/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/svcs/nix/default.nix')
-rw-r--r--sys/svcs/nix/default.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys/svcs/nix/default.nix b/sys/svcs/nix/default.nix
index 9b05af1f..24c72b97 100644
--- a/sys/svcs/nix/default.nix
+++ b/sys/svcs/nix/default.nix
@@ -8,11 +8,9 @@
   ...
 }: {
   nix = {
-    package = pkgs.nixUnstable;
+    package = pkgs.nixVersions.latest;
 
-    # Disable the NixPath (this is but a remnant of old days)
-    # In the `nix repl` you should simply replace your `:l <nixpkgs>` with `:lf nixpgks`
-    nixPath = lib.mkForce [];
+    # Disable nix channels  (this is a remnant of old days)
     channel.enable = false;
 
     registry = {
@@ -30,6 +28,7 @@
       dates = "weekly";
       options = "--delete-older-than 7d";
     };
+
     settings = {
       auto-optimise-store = true;
       experimental-features = [
@@ -48,8 +47,7 @@
       keep-failed = true; # keep failed tmp build dirs
       pure-eval = true; # restrict file system and network access to hash
 
-      sandbox-fallback = false; # Don't disable the sandbox, if the kernel doesn't support
-      # it
+      sandbox-fallback = false; # Don't disable the sandbox, if the kernel doesn't support it
     };
   };
 }