about summary refs log tree commit diff stats
path: root/sys/svcs/getty/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sys/svcs/getty/default.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys/svcs/getty/default.nix b/sys/svcs/getty/default.nix
new file mode 100644
index 00000000..aefdb1b4
--- /dev/null
+++ b/sys/svcs/getty/default.nix
@@ -0,0 +1,42 @@
+{
+  lib,
+  config,
+  ...
+}: {
+  services.getty = {
+    greetingLine = lib.mkForce ''
+      [?25l[?7l                                           
+                ▗▄▄▄       ▗▄▄▄▄    ▄▄▄▖         
+                ▜███▙       ▜███▙  ▟███▛         
+                 ▜███▙       ▜███▙▟███▛          
+                  ▜███▙       ▜██████▛           
+           ▟█████████████████▙ ▜████▛     ▟▙     
+          ▟███████████████████▙ ▜███▙    ▟██▙    
+                 ▄▄▄▄▖           ▜███▙  ▟███▛    
+                ▟███▛             ▜██▛ ▟███▛     
+               ▟███▛               ▜▛ ▟███▛      
+      ▟███████████▛                  ▟██████████▙
+      ▜██████████▛                  ▟███████████▛
+            ▟███▛ ▟▙               ▟███▛         
+           ▟███▛ ▟██▙             ▟███▛          
+          ▟███▛  ▜███▙           ▝▀▀▀▀           
+          ▜██▛    ▜███▙ ▜██████████████████▛     
+           ▜▛     ▟████▙ ▜████████████████▛      
+                 ▟██████▙       ▜███▙            
+                ▟███▛▜███▙       ▜███▙           
+               ▟███▛  ▜███▙       ▜███▙          
+               ▝▀▀▀    ▀▀▀▀▘       ▀▀▀▘          
+                                                 
+        NixOS ${config.system.nixos.label} 
+        --------------
+      
+        date: \d
+        time: \t
+        ipv4: \4
+        ipv6: \6
+        tty: \l
+      
+    '';
+    autologinUser = "soispha";
+  };
+}