about summary refs log tree commit diff stats
path: root/services/openssh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--services/openssh/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/services/openssh/default.nix b/services/openssh/default.nix
new file mode 100644
index 00000000..5ee48a0c
--- /dev/null
+++ b/services/openssh/default.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  pkg,
+  ...
+}: {
+  services.openssh = {
+    enable = true;
+    hostKeys = [
+      {
+        path = "/srv/sshd/ssh_host_ed25519_key";
+        rounds = 1000;
+        type = "ed25519";
+      }
+    ];
+    settings = {
+      PasswordAuthentication = false;
+    };
+  };
+}