about summary refs log tree commit diff stats
path: root/services/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/nix/default.nix')
-rw-r--r--services/nix/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/services/nix/default.nix b/services/nix/default.nix
new file mode 100644
index 00000000..27f9b170
--- /dev/null
+++ b/services/nix/default.nix
@@ -0,0 +1,22 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: {
+  nix = {
+    gc = {
+      automatic = true;
+      dates = "daily";
+      options = "--delete-older-than 3";
+    };
+    settings = {
+      auto-optimise-store = true;
+      experimental-features = ["nix-command" "flakes"];
+      fallback = true;
+
+      keep-failed = true; #keep failed tmp build dirs
+      pure-eval = true; # restrict file system and network access to  hash
+    };
+  };
+}