about summary refs log tree commit diff stats
path: root/pkgs/sources/comments/comments.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sources/comments/comments.nix')
-rw-r--r--pkgs/sources/comments/comments.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/sources/comments/comments.nix b/pkgs/sources/comments/comments.nix
new file mode 100644
index 00000000..e8a33bff
--- /dev/null
+++ b/pkgs/sources/comments/comments.nix
@@ -0,0 +1,25 @@
+{
+  lib,
+  rustPlatform,
+  makeWrapper,
+  less,
+  coreutils,
+}:
+rustPlatform.buildRustPackage {
+  pname = "comments";
+  version = "0.1.0";
+
+  src = ./.;
+  cargoLock = {
+    lockFile = ./Cargo.lock;
+  };
+
+  nativeBuildInputs = [
+    makeWrapper
+  ];
+
+  postInstall = ''
+    wrapProgram $out/bin/comments \
+      --set PATH ${lib.makeBinPath [less coreutils]}
+  '';
+}