about summary refs log tree commit diff stats
path: root/pkgs/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pkgs/overlay.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/overlay.nix b/pkgs/overlay.nix
new file mode 100644
index 00000000..14d20fbd
--- /dev/null
+++ b/pkgs/overlay.nix
@@ -0,0 +1,16 @@
+# You can use this file as a nixpkgs overlay. This is useful in the
+# case where you don't want to add the whole NUR namespace to your
+# configuration.
+{sysLib}: self: super: let
+  nameValuePair = n: v: {
+    name = n;
+    value = v;
+  };
+  packages = import ./default.nix {
+    pkgs = super;
+    inherit sysLib;
+  };
+in
+  builtins.listToAttrs
+  (map (n: nameValuePair n packages.${n})
+    (builtins.attrNames packages))