about summary refs log tree commit diff stats
path: root/modules/system/services/scanning/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/system/services/scanning/default.nix')
-rw-r--r--modules/system/services/scanning/default.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/modules/system/services/scanning/default.nix b/modules/system/services/scanning/default.nix
deleted file mode 100644
index dda507fa..00000000
--- a/modules/system/services/scanning/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}: let
-  cfg = config.soispha.services.scanning;
-in {
-  options.soispha.services.scanning = {
-    enable = lib.mkEnableOption "default scanning configuration";
-  };
-
-  config = lib.mkIf cfg.enable {
-    hardware = {
-      sane = {
-        enable = true;
-        extraBackends = [pkgs.sane-airscan];
-      };
-    };
-
-    users.users.soispha.extraGroups = [
-      "scanner" # for permission to access the scanner.
-    ];
-  };
-}