about summary refs log tree commit diff stats
path: root/modules/system/cleanup/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/system/cleanup/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/system/cleanup/default.nix b/modules/system/cleanup/default.nix
new file mode 100644
index 00000000..4e192f7d
--- /dev/null
+++ b/modules/system/cleanup/default.nix
@@ -0,0 +1,18 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.cleanup;
+in {
+  # remove all the bloat, which NixOS installs by default
+  options.soispha.cleanup = {
+    enable = lib.mkEnableOption "avoiding of nixos' default installed packages";
+  };
+
+  config = lib.mkIf cfg.enable {
+    environment = {
+      defaultPackages = lib.mkForce [];
+    };
+  };
+}