about summary refs log tree commit diff stats
path: root/modules/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/default.nix')
-rw-r--r--modules/home/default.nix60
1 files changed, 0 insertions, 60 deletions
diff --git a/modules/home/default.nix b/modules/home/default.nix
deleted file mode 100644
index 574ed66a..00000000
--- a/modules/home/default.nix
+++ /dev/null
@@ -1,60 +0,0 @@
-{
-  impermanence,
-  nixVim,
-  nix-index-database,
-  ...
-}: let
-  username = "soispha";
-  homeDirectory = "/home/${username}";
-
-  # xdg
-  configHome = "${homeDirectory}/.config";
-  dataHome = "${homeDirectory}/.local/share";
-  stateHome = "${homeDirectory}/.local/state";
-  cacheHome = "${homeDirectory}/.cache";
-  binHome = "${homeDirectory}/.local/bin";
-  # TODO: add XDG_RUNTIME_DIR
-in {
-  imports = [
-    ./conf
-    ./files
-    ./impermanence
-    ./pkgs
-    ./wms
-
-    impermanence.nixosModules.home-manager.impermanence
-    nixVim.homeManagerModules.nixvim
-    nix-index-database.hmModules.nix-index
-  ];
-
-  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
-  programs.home-manager.enable = true;
-
-  home = {
-    inherit username homeDirectory;
-    stateVersion = "23.05";
-    enableNixpkgsReleaseCheck = true;
-  };
-  xdg = {
-    enable = true;
-    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO: add binHome, when the standard is extended
-
-    /*
-    TODO: add this
-    desktopEntries = {};
-    */
-
-    userDirs = {
-      enable = true;
-      createDirectories = true;
-      desktop = null;
-      documents = "${homeDirectory}/school/general";
-      download = "${homeDirectory}/media/downloads";
-      music = "${homeDirectory}/media/music";
-      pictures = "${homeDirectory}/media/pictures";
-      videos = "${homeDirectory}/media/videos";
-      templates = "${homeDirectory}/media/templates";
-      publicShare = "${homeDirectory}/media/public";
-    };
-  };
-}