about summary refs log tree commit diff stats
path: root/modules/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/home/default.nix94
1 files changed, 53 insertions, 41 deletions
diff --git a/modules/home/default.nix b/modules/home/default.nix
index b0311261..a6107898 100644
--- a/modules/home/default.nix
+++ b/modules/home/default.nix
@@ -1,48 +1,60 @@
 {
-  pkgs,
-  sysLib,
-  nixpkgs_open_prs,
-  # extra information
-  system,
-  # bins
-  yambar_cpu,
-  yambar_memory,
-  river_init_lesser,
-  shell_library,
-  # external deps
-  user_js,
-  # modules
   impermanence,
   nixVim,
   nix-index-database,
-}: {
-  home-manager = {
-    useGlobalPkgs = true;
-    useUserPackages = true;
-    users.soispha = import ./soispha;
-    extraSpecialArgs = {
-      inherit
-        pkgs
-        nixpkgs_open_prs
-        sysLib
-        # extra information
-        
-        system
-        # bins
-        
-        yambar_cpu
-        yambar_memory
-        river_init_lesser
-        shell_library
-        # external deps
-        
-        user_js
-        # modules
-        
-        impermanence
-        nixVim
-        nix-index-database
-        ;
+  ...
+}: let
+  username = "soispha";
+  homeDirectory = "/home/${username}";
+
+  # xdg
+  configHome = "${homeDirectory}/.config";
+  dataHome = "${homeDirectory}/.local/share";
+  stateHome = "${homeDirectory}/.local/state";
+  cacheHome = "${homeDirectory}/.cache";
+  binHome = "${homeDirectory}/.local/bin";
+  # TODO: add XDG_RUNTIME_DIR
+in {
+  imports = [
+    ./conf
+    ./files
+    ./impermanence
+    ./pkgs
+    ./wms
+
+    impermanence.nixosModules.home-manager.impermanence
+    nixVim.homeManagerModules.nixvim
+    nix-index-database.hmModules.nix-index
+  ];
+
+  # I don't know what this does, but I've seen it a lot online, so it should be good, right?
+  programs.home-manager.enable = true;
+
+  home = {
+    inherit username homeDirectory;
+    stateVersion = "23.05";
+    enableNixpkgsReleaseCheck = true;
+  };
+  xdg = {
+    enable = true;
+    inherit configHome dataHome stateHome cacheHome; #binHome; # TODO: add binHome, when the standart is extended
+
+    /*
+    TODO: add this
+    desktopEntries = {};
+    */
+
+    userDirs = {
+      enable = true;
+      createDirectories = true;
+      desktop = null;
+      documents = "${homeDirectory}/school/general";
+      download = "${homeDirectory}/media/downloads";
+      music = "${homeDirectory}/media/music";
+      pictures = "${homeDirectory}/media/pictures";
+      videos = "${homeDirectory}/media/videos";
+      templates = "${homeDirectory}/media/templates";
+      publicShare = "${homeDirectory}/media/public";
     };
   };
 }