about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/plgs/treesitter/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/conf/nvim/plgs/treesitter/default.nix')
-rw-r--r--modules/home/conf/nvim/plgs/treesitter/default.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/home/conf/nvim/plgs/treesitter/default.nix b/modules/home/conf/nvim/plgs/treesitter/default.nix
index 656b4ce3..13d27348 100644
--- a/modules/home/conf/nvim/plgs/treesitter/default.nix
+++ b/modules/home/conf/nvim/plgs/treesitter/default.nix
@@ -1,5 +1,4 @@
 {
-  osConfig,
   config,
   pkgs,
   lib,
@@ -17,7 +16,7 @@
 
       grammarPackages =
         config.programs.nixvim.plugins.treesitter.package.passthru.allGrammars
-        ++ [pkgs.yts-grammar];
+        ++ [pkgs.tree-sitter-yts];
 
       disabledLanguages = [];
 
@@ -49,7 +48,7 @@
     };
     extraFiles = {
       "queries/yts/highlights.scm" = ''
-        ${lib.strings.fileContents "${pkgs.yts-grammar}/queries/highlights.scm"}
+        ${lib.strings.fileContents "${pkgs.tree-sitter-yts}/queries/highlights.scm"}
       '';
     };
   };