about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/plgs/debugprint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/home/conf/nvim/plgs/debugprint/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/modules/home/conf/nvim/plgs/debugprint/default.nix b/modules/home/conf/nvim/plgs/debugprint/default.nix
index b0d72339..3c591e9f 100644
--- a/modules/home/conf/nvim/plgs/debugprint/default.nix
+++ b/modules/home/conf/nvim/plgs/debugprint/default.nix
@@ -16,12 +16,11 @@
       {
         key = "g?v";
         mode = ["v" "n"];
-        action = ''
+        action.__raw = ''
           function()
             return require('debugprint').debugprint({variable = true;});
           end
         '';
-        lua = true;
         options.expr = true;
         options.desc = ''
           'variable' debug line below the current line
@@ -30,12 +29,11 @@
       {
         key = "g?V";
         mode = ["v" "n"];
-        action = ''
+        action.__raw = ''
           function()
             return require('debugprint').debugprint({above = true; variable = true;}) ;
           end
         '';
-        lua = true;
         options.expr = true;
         options.desc = ''
           'variable' debug line above the current line
@@ -44,12 +42,11 @@
       {
         key = "g?p";
         mode = "n";
-        action = ''
+        action.__raw = ''
           function()
             return require('debugprint').debugprint();
           end
         '';
-        lua = true;
         options.expr = true;
         options.desc = ''
           'plain' debug line below the current line
@@ -58,12 +55,11 @@
       {
         key = "g?P";
         mode = "n";
-        action = ''
+        action.__raw = ''
           function()
             return require('debugprint').debugprint({above = true;});
           end
         '';
-        lua = true;
         options.expr = true;
         options.desc = ''
           'plain' debug line above the current line