about summary refs log tree commit diff stats
path: root/modules/home/conf/nvim/mappings/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/conf/nvim/mappings/default.nix')
-rw-r--r--modules/home/conf/nvim/mappings/default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/modules/home/conf/nvim/mappings/default.nix b/modules/home/conf/nvim/mappings/default.nix
index 2cb174a4..af800d22 100644
--- a/modules/home/conf/nvim/mappings/default.nix
+++ b/modules/home/conf/nvim/mappings/default.nix
@@ -14,7 +14,7 @@
       {
         key = "hh";
         mode = ["i"];
-        action = ''
+        action.__raw = ''
           function()
             local cmp = require('cmp');
             local luasnip = require('luasnip');
@@ -26,19 +26,17 @@
             end
           end
         '';
-        lua = true;
         options.desc = "completion trigger/ forward in completen menu";
       }
       {
         key = "uu";
         mode = ["i"];
-        action = ''
+        action.__raw = ''
           function()
             local cmp = require('cmp');
             cmp.confirm()
           end
         '';
-        lua = true;
         options.desc = "confirm the selected item";
       }
 
@@ -171,8 +169,7 @@
       {
         mode = ["n"];
         key = "\\f";
-        action = "function() require('lf').start() end";
-        lua = true;
+        action.__raw = "function() require('lf').start() end";
         options.desc = "open lf in a floating window";
       }
 
@@ -224,7 +221,7 @@
       {
         key = "dd";
         mode = ["n"];
-        action = ''
+        action.__raw = ''
           function()
             if vim.api.nvim_get_current_line():match("^%s*$") then
               return '"_dd'
@@ -233,7 +230,6 @@
             end
           end
         '';
-        lua = true;
         options = {
           desc = "Pipe all blank line deletions to the blackhole register";
           expr = true;