about summary refs log tree commit diff stats
path: root/modules/home/conf/beets/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/conf/beets/default.nix')
-rw-r--r--modules/home/conf/beets/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/home/conf/beets/default.nix b/modules/home/conf/beets/default.nix
index 88073143..9b88db88 100644
--- a/modules/home/conf/beets/default.nix
+++ b/modules/home/conf/beets/default.nix
@@ -11,6 +11,7 @@
         beatport.enable = true;
       };
     };
+
     settings = {
       library = "${config.xdg.dataHome}/beets/library.db";
       art_filename = "cover";
@@ -18,6 +19,11 @@
       ui = {
         color = true;
       };
+
+      include = [
+        "./replace_override.yaml"
+      ];
+
       import = {
         # move, instead of copying or linking the files
         copy = false;
@@ -230,6 +236,8 @@
     };
   };
 
+  xdg.configFile."beets/replace_override.yaml".source = ./replace_override.yaml;
+
   # Use the json formatter instead of the YAML one, as the YAML formatter mangles the
   # longer python inline strings.
   # YAML is a superset of JSON.