about summary refs log tree commit diff stats
path: root/modules/home/conf/alacritty/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/conf/alacritty/default.nix')
-rw-r--r--modules/home/conf/alacritty/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/home/conf/alacritty/default.nix b/modules/home/conf/alacritty/default.nix
deleted file mode 100644
index c1cf5e44..00000000
--- a/modules/home/conf/alacritty/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{lib, ...}: let
-  config_file = ''
-    ${lib.strings.fileContents ./toml/base.toml}
-    ${lib.strings.fileContents ./toml/bell.toml}
-    ${lib.strings.fileContents ./toml/colorscheme.toml}
-    ${lib.strings.fileContents ./toml/cursor.toml}
-    ${lib.strings.fileContents ./toml/env.toml}
-    ${lib.strings.fileContents ./toml/font.toml}
-    ${lib.strings.fileContents ./toml/hints.toml}
-    ${lib.strings.fileContents ./toml/keyboard_bindings.toml}
-    ${lib.strings.fileContents ./toml/mouse.toml}
-    ${lib.strings.fileContents ./toml/mouse_bindings.toml}
-    ${lib.strings.fileContents ./toml/scrolling.toml}
-    ${lib.strings.fileContents ./toml/selection.toml}
-    ${lib.strings.fileContents ./toml/window.toml}
-  '';
-in {
-  home.sessionVariables = {
-    # This is **not** the TERM variable but a special one to signify my favorite terminal.
-    TERMINAL = "alacritty";
-
-    # These two here should be set by alacritty at start-up
-    # TERM = "alacritty";
-    # COLORTERM = "truecolor";
-  };
-  programs.alacritty = {
-    enable = true;
-  };
-  xdg.configFile."alacritty/alacritty.toml".text = config_file;
-}