about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/nvim/plgs/lsp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/nvim/plgs/lsp/default.nix')
-rw-r--r--modules/home.legacy/conf/nvim/plgs/lsp/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/lsp/default.nix b/modules/home.legacy/conf/nvim/plgs/lsp/default.nix
new file mode 100644
index 00000000..b7c1e174
--- /dev/null
+++ b/modules/home.legacy/conf/nvim/plgs/lsp/default.nix
@@ -0,0 +1,29 @@
+{...}: {
+  imports = [
+    ./keymaps
+    ./servers
+  ];
+  programs.nixvim.plugins.lsp = {
+    enable = true;
+    onAttach =
+      ""
+      #     + ''
+      #        function(client, bufnr)
+      #            -- Enable completion triggered by <c-x><c-o>
+      #            -- vim.api.nvim_buf_set_option(bufnr, 'omnifunc', 'v:lua.vim.lsp.omnifunc')
+      #        end
+      #      ''
+      ;
+    preConfig = ''
+      vim.diagnostic.config({
+          underline = true,
+          -- virtual_text = true,
+          virtual_text = {
+              source = "always", -- Or "if_many"
+          },
+          update_in_insert = true,
+          severity_sort = true,
+      }, nil);
+    '';
+  };
+}