about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/gammastep/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home.legacy/conf/gammastep/default.nix')
-rw-r--r--modules/home.legacy/conf/gammastep/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/home.legacy/conf/gammastep/default.nix b/modules/home.legacy/conf/gammastep/default.nix
new file mode 100644
index 00000000..1ae0550b
--- /dev/null
+++ b/modules/home.legacy/conf/gammastep/default.nix
@@ -0,0 +1,29 @@
+{
+  lib,
+  nixosConfig,
+  ...
+}: let
+  temp =
+    if nixosConfig.soispha.laptop.enable
+    then 3000
+    else 1300;
+in {
+  services.gammastep = {
+    enable = true;
+    settings = {
+      general = {
+        temp-day = lib.mkForce temp;
+        temp-night = lib.mkForce temp;
+        gamma = "0.8:0.8:0.8";
+        fade = 0;
+        adjustment-method = "wayland";
+        location-provider = "manual";
+      };
+
+      manual = {
+        lat = 48.1;
+        lon = 11.6;
+      };
+    };
+  };
+}