about summary refs log tree commit diff stats
path: root/modules/by-name/te/tempfiles/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/te/tempfiles/module.nix')
-rw-r--r--modules/by-name/te/tempfiles/module.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/by-name/te/tempfiles/module.nix b/modules/by-name/te/tempfiles/module.nix
new file mode 100644
index 00000000..f8bfd4dc
--- /dev/null
+++ b/modules/by-name/te/tempfiles/module.nix
@@ -0,0 +1,20 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.tempfiles;
+in {
+  options.soispha.tempfiles = {
+    enable = lib.mkEnableOption "systemd tempfiles generation";
+  };
+
+  config = lib.mkIf cfg.enable {
+    systemd.tmpfiles.rules = [
+      # TODO: Find a way to move this file to the lf home manager config.
+      #
+      # This file is needed to trash stuff on the root ('/') temp file system.
+      "d /.Trash 1777 root root"
+    ];
+  };
+}