about summary refs log tree commit diff stats
path: root/modules/by-name/ta/taskwarrior/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/ta/taskwarrior/module.nix')
-rw-r--r--modules/by-name/ta/taskwarrior/module.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/modules/by-name/ta/taskwarrior/module.nix b/modules/by-name/ta/taskwarrior/module.nix
new file mode 100644
index 00000000..ff1569af
--- /dev/null
+++ b/modules/by-name/ta/taskwarrior/module.nix
@@ -0,0 +1,35 @@
+{...}: {
+  # HACK: Migrating the whole `taskwarrior` setup is right now unrealistic, as the module is
+  # tightly coupled with the `firefox` module, and `neorg` script.
+  # But to work around the  fact that setting the `age` secrets in the legacy module is
+  # impossible, this module was created as work-around until the `taskwarrior` module can
+  # be fully migrated. <2024-10-18>
+  config = {
+    age.secrets = {
+      taskserverPrivate = {
+        file = ./secrets/private.key;
+        mode = "700";
+        owner = "soispha";
+        group = "users";
+      };
+      taskserverPublic = {
+        file = ./secrets/public.cert;
+        mode = "700";
+        owner = "soispha";
+        group = "users";
+      };
+      taskserverCA = {
+        file = ./secrets/ca.cert;
+        mode = "700";
+        owner = "soispha";
+        group = "users";
+      };
+      taskserverCredentials = {
+        file = ./secrets/credentials;
+        mode = "700";
+        owner = "soispha";
+        group = "users";
+      };
+    };
+  };
+}