about summary refs log tree commit diff stats
path: root/modules/by-name/ta/taskwarrior/module.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/by-name/ta/taskwarrior/module.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/modules/by-name/ta/taskwarrior/module.nix b/modules/by-name/ta/taskwarrior/module.nix
index ff1569af..0a942820 100644
--- a/modules/by-name/ta/taskwarrior/module.nix
+++ b/modules/by-name/ta/taskwarrior/module.nix
@@ -1,10 +1,20 @@
-{...}: {
+{
+  lib,
+  config,
+  ...
+}: let
+  cfg = config.soispha.programs.taskwarrior;
+in {
+  options.soispha.programs.taskwarrior = {
+    enable = lib.mkEnableOption "taskwarrior-secrets";
+  };
+
   # HACK: Migrating the whole `taskwarrior` setup is right now unrealistic, as the module is
   # tightly coupled with the `firefox` module, and `neorg` script.
   # But to work around the  fact that setting the `age` secrets in the legacy module is
   # impossible, this module was created as work-around until the `taskwarrior` module can
   # be fully migrated. <2024-10-18>
-  config = {
+  config = lib.mkIf cfg.enable {
     age.secrets = {
       taskserverPrivate = {
         file = ./secrets/private.key;