about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/nvim-cmp/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/by-name/nv/nvim/plgs/nvim-cmp/default.nix (renamed from modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix)39
1 files changed, 19 insertions, 20 deletions
diff --git a/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix b/modules/by-name/nv/nvim/plgs/nvim-cmp/default.nix
index ed0e57c3..8d61dbd7 100644
--- a/modules/home.legacy/conf/nvim/plgs/nvim-cmp/default.nix
+++ b/modules/by-name/nv/nvim/plgs/nvim-cmp/default.nix
@@ -1,10 +1,11 @@
-{config, ...}: {
-  programs.nixvim.plugins.cmp = let
-    neorg_source =
-      if config.programs.nixvim.plugins.neorg.modules."core.completion".config.engine == "nvim-cmp"
-      then [{name = "neorg";}]
-      else [];
-  in {
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim.plugins.cmp = lib.mkIf cfg.enable {
     /*
     TODO: integrate this:
     ```lua
@@ -36,19 +37,17 @@
 
       snippet.expand = "function(args) require('luasnip').lsp_expand(args.body) end";
 
-      sources =
-        [
-          {name = "nvim_lsp";}
-          {name = "luasnip";}
-          {name = "path";}
-          {name = "git";} # TODO: I might want to add config to allow all issues/prs <2023-10-16>
-          # {name = "convertionalcommits";} # TODO: Useless without commitlint [https://commitlint.js.org/] <2023-10-16>
-          # {name = "rg";} # TODO: This might really RIP-grep my system <2023-10-16>
-          # {name = "buffer";}
-          # {name = "digraphs";}
-          {name = "calc";}
-        ]
-        ++ neorg_source;
+      sources = [
+        {name = "nvim_lsp";}
+        {name = "luasnip";}
+        {name = "path";}
+        {name = "git";} # TODO: I might want to add config to allow all issues/prs <2023-10-16>
+        # {name = "convertionalcommits";} # TODO: Useless without commitlint [https://commitlint.js.org/] <2023-10-16>
+        # {name = "rg";} # TODO: This might really RIP-grep my system <2023-10-16>
+        # {name = "buffer";}
+        # {name = "digraphs";}
+        {name = "calc";}
+      ];
     };
   };
 }