about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/plgs/comment-nvim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/nv/nvim/plgs/comment-nvim/default.nix')
-rw-r--r--modules/by-name/nv/nvim/plgs/comment-nvim/default.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/modules/by-name/nv/nvim/plgs/comment-nvim/default.nix b/modules/by-name/nv/nvim/plgs/comment-nvim/default.nix
new file mode 100644
index 00000000..bd70c5c2
--- /dev/null
+++ b/modules/by-name/nv/nvim/plgs/comment-nvim/default.nix
@@ -0,0 +1,47 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim = lib.mkIf cfg.enable {
+    plugins.comment = {
+      enable = true;
+      settings = {
+        padding = true;
+        sticky = true;
+        mappings = {
+          basic = false;
+          extra = false;
+        };
+      };
+    };
+    keymaps = [
+      {
+        key = "gcc";
+        mode = "v";
+        action = "<Plug>(comment_toggle_linewise_visual)";
+        options.desc = "toggle the current line in a linewise comment";
+      }
+      {
+        key = "gbc";
+        mode = "v";
+        action = "<Plug>(comment_toggle_blockwise_visual)";
+        options.desc = "toggle the current line in a blockwise comment";
+      }
+      {
+        key = "gcc";
+        mode = "n";
+        action = "<Plug>(comment_toggle_linewise_current)";
+        options.desc = "toggle the current line in a linewise comment";
+      }
+      {
+        key = "gbc";
+        mode = "n";
+        action = "<Plug>(comment_toggle_blockwise_current)";
+        options.desc = "toggle the current line in a blockwise comment";
+      }
+    ];
+  };
+}