about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware/gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/tiamat/hardware/gpu.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/hosts/tiamat/hardware/gpu.nix b/hosts/tiamat/hardware/gpu.nix
index 9649c770..6a28eaa4 100644
--- a/hosts/tiamat/hardware/gpu.nix
+++ b/hosts/tiamat/hardware/gpu.nix
@@ -4,11 +4,23 @@
   lib,
   ...
 }: {
+  #   hardware.opengl.extraPackages = with pkgs; [
+  #     rocm-opencl-icd # open-cl
+  #     amdvlk # or directly through mesa
+  #     amd-media-driver # libva
+  #   ];
+  #
+  #   # Force radv, TODO is this logical?
+  #   environment.variables.AMD_VULKAN_ICD = "RADV";
+
   hardware.opengl = {
     enable = true;
     extraPackages = with pkgs; [
       vaapiVdpau
       libvdpau-va-gl
+
+       amdvlk # or directly through mesa
+       amd-media-driver # libva
     ];
   };
 }