about summary refs log tree commit diff stats
path: root/hosts/tiamat/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/tiamat/hardware/default.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/hosts/tiamat/hardware/default.nix b/hosts/tiamat/hardware/default.nix
index bd7241b3..595c07c0 100644
--- a/hosts/tiamat/hardware/default.nix
+++ b/hosts/tiamat/hardware/default.nix
@@ -11,18 +11,22 @@
     ./gpu.nix
   ];
 
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+  nixpkgs.hostPlatform = "x86_64-linux";
 
   system.fileSystemLayouts = {
     enable = true;
-    mainDisk = "/dev/disk/by-uuid/<uuid>";
-    efiDisk = "/dev/disk/by-uuid/<uuid>";
+    mainDisk = "/dev/disk/by-uuid/4211a4ff-f2e9-41ed-83ca-712830fd0254";
+    efiDisk = "/dev/disk/by-uuid/2BFA-8F0F";
+    ssd = true;
+    swap = {
+      uuid = "4211a4ff-f2e9-41ed-83ca-712830fd0254";
+      resumeOffset = "533760";
+    };
   };
 
   boot = {
     kernelModules = ["kvm-amd"];
 
-    # TODO check this:
-    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+    initrd.availableKernelModules = ["ahci" "xhci_pci" "virtio_pci" "nvme" "sr_mod" "virtio_blk"];
   };
 }