about summary refs log tree commit diff stats
path: root/hosts/spawn/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/spawn/hardware/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/hosts/spawn/hardware/default.nix b/hosts/spawn/hardware/default.nix
new file mode 100644
index 00000000..f6500ed5
--- /dev/null
+++ b/hosts/spawn/hardware/default.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+    (modulesPath + "/installer/scan/detected.nix")
+    # (modulesPath + "/installer/cd-dvd/installation-cd-base.nix")
+
+    (modulesPath + "/profiles/base.nix")
+    (modulesPath + "/profiles/minimal.nix")
+    (modulesPath + "/profiles/all-hardware.nix")
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/<uuid>";
+    efiDisk = "/dev/disk/by-uuid/<uuid>";
+  };
+
+  boot = {
+  };
+}