about summary refs log tree commit diff stats
path: root/hosts/mammun_on_vm/hardware/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/mammun_on_vm/hardware/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/hosts/mammun_on_vm/hardware/default.nix b/hosts/mammun_on_vm/hardware/default.nix
new file mode 100644
index 00000000..e9766f05
--- /dev/null
+++ b/hosts/mammun_on_vm/hardware/default.nix
@@ -0,0 +1,27 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/b1974623-df36-4367-bf12-c0778cd8ff33";
+    efiDisk = "/dev/disk/by-uuid/201D-E6E7";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    initrd.availableKernelModules = ["xhci_pci" "ahci" "ehci_pci" "sd_mod" "sr_mod" "sdhci_pci"];
+  };
+}