about summary refs log tree commit diff stats
path: root/hosts/mammun/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/mammun/networking.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/hosts/mammun/networking.nix b/hosts/mammun/networking.nix
index 05c7d100..1ebd0a7c 100644
--- a/hosts/mammun/networking.nix
+++ b/hosts/mammun/networking.nix
@@ -3,12 +3,14 @@
   lib,
   ...
 }: {
-  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
-  # (the default) this is the recommended approach. When using systemd-networkd it's
-  # still possible to use this option, but it's recommended to use it in conjunction
-  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
-  networking.useDHCP = lib.mkDefault true;
-  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
-  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
-  networking.hostName = "mammun";
+  networking = {
+    networkmanager = {
+      enable = true;
+      dns = "systemd-resolved";
+      wifi = {
+        powersave = true;
+      };
+    };
+    hostName = "mammun";
+  };
 }