about summary refs log tree commit diff stats
path: root/hosts/laptop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/laptop/configuration.nix')
-rw-r--r--hosts/laptop/configuration.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/laptop/configuration.nix b/hosts/laptop/configuration.nix
new file mode 100644
index 00000000..8e78949b
--- /dev/null
+++ b/hosts/laptop/configuration.nix
@@ -0,0 +1,19 @@
+# vim: ts=2
+{
+  config,
+  lib,
+  nixpkgs,
+  home-manager,
+  ...
+}: {
+  imports = [
+    ./hardware
+    ./networking.nix
+
+    ../../system
+
+    ../../services
+  ];
+
+  system.stateVersion = "23.05";
+}