about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/IDOHVE/hardware/hardware.nix')
-rw-r--r--hosts/IDOHVE/hardware/hardware.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/hosts/IDOHVE/hardware/hardware.nix b/hosts/IDOHVE/hardware/hardware.nix
deleted file mode 100644
index c36b7062..00000000
--- a/hosts/IDOHVE/hardware/hardware.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  modulesPath,
-  ...
-}: {
-  imports = [
-    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
-    ./cpu.nix
-    ./gpu.nix
-  ];
-
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-
-  system.filesystemLayouts = {
-    enable = true;
-    mainDisk = "/dev/disk/by-uuid/<uuid>";
-    efiDisk = "/dev/disk/by-uuid/<uuid>";
-  };
-
-  boot = {
-    kernelModules = ["kvm-amd"];
-
-    # TODO check this:
-    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
-  };
-}