about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/hardware.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/IDOHVE/hardware/hardware.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/IDOHVE/hardware/hardware.nix b/hosts/IDOHVE/hardware/hardware.nix
new file mode 100644
index 00000000..20e4c4f3
--- /dev/null
+++ b/hosts/IDOHVE/hardware/hardware.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}:{
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    ./cpu.nix
+    ./gpu.nix
+    ./boot.nix
+    ./filesystems.nix
+  ];
+
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}
+