about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/IDOHVE/hardware/gpu.nix')
-rw-r--r--hosts/IDOHVE/hardware/gpu.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/hosts/IDOHVE/hardware/gpu.nix b/hosts/IDOHVE/hardware/gpu.nix
new file mode 100644
index 00000000..49197c2b
--- /dev/null
+++ b/hosts/IDOHVE/hardware/gpu.nix
@@ -0,0 +1,16 @@
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}: {
+
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd # open-cl
+    amdvlk # or directly through mesa
+    amd-media-driver # libva
+  ];
+
+  # Force radv, TODO is this logical?
+  environment.variables.AMD_VULKAN_ICD = "RADV";
+}