about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/filesystems.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/IDOHVE/hardware/filesystems.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/hosts/IDOHVE/hardware/filesystems.nix b/hosts/IDOHVE/hardware/filesystems.nix
new file mode 100644
index 00000000..a188df18
--- /dev/null
+++ b/hosts/IDOHVE/hardware/filesystems.nix
@@ -0,0 +1,41 @@
+{config, ...}: let
+  main_disk = "/dev/disk/by-uuid/<uuid>";
+in {
+  fileSystems = {
+    "/" = {
+      device = "none";
+      fsType = "tmpfs";
+      options = ["defaults" "size=2G" "mode=755"];
+    };
+    "/nix" = {
+      device = main_disk;
+      fsType = "btrfs";
+      options = ["subvol=@nix" "compress-force=zstd:9"];
+    };
+    "/boot" = {
+      device = "/dev/disk/by-uuid/<uuid>";
+      fsType = "vfat";
+    };
+
+    "/srv/home" = {
+      device = main_disk;
+      fsType = "btrfs";
+      options = ["subvol=@home" "compress-force=zstd:9"];
+    };
+    "/srv/nixos-config" = {
+      device = main_disk;
+      fsType = "btrfs";
+      options = ["subvol=@nixos-config" "compress-force=zstd:9"];
+    };
+
+    "/etc/nixos" = {
+      device = "/srv/nix-config";
+      options = ["bind"];
+    };
+    "/home" = {
+      device = "/srv/home";
+      options = ["bind"];
+    };
+  };
+  swapDevices = [];
+}