about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/IDOHVE/hardware/boot.nix')
-rw-r--r--hosts/IDOHVE/hardware/boot.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hosts/IDOHVE/hardware/boot.nix b/hosts/IDOHVE/hardware/boot.nix
new file mode 100644
index 00000000..932155a4
--- /dev/null
+++ b/hosts/IDOHVE/hardware/boot.nix
@@ -0,0 +1,32 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  boot = {
+    initrd = {
+      compressor = "lz4";
+      compressorArgs = ["-9"];
+
+      # TODO check this:
+      availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+    };
+
+    kernelModules = ["kvm-amd"];
+    kernelPackages = pkgs.linuxPackages_latest;
+    loader = {
+      grub = {
+        enable = true;
+        version = 2;
+        theme = pkgs.nixos-grub2-theme;
+        splashImage = ./grub_boot_image.png;
+        efiSupport = true;
+        device = "nodev"; # only for efi
+      };
+      efi = {
+        canTouchEfiVariables = true;
+        efiSysMountPoint = "/boot";
+      };
+    };
+  };
+}