about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/IDOHVE/hardware/boot.nix')
-rw-r--r--hosts/IDOHVE/hardware/boot.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/hosts/IDOHVE/hardware/boot.nix b/hosts/IDOHVE/hardware/boot.nix
deleted file mode 100644
index 4cd94191..00000000
--- a/hosts/IDOHVE/hardware/boot.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{
-  config,
-  pkgs,
-  ...
-}: {
-  boot = {
-    initrd = {
-      compressor = "lz4";
-      compressorArgs = ["-9"];
-
-      # TODO check this:
-      availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
-    };
-
-    kernelModules = ["kvm-amd"];
-    kernelPackages = pkgs.linuxPackages_latest;
-    loader = {
-      grub = {
-        enable = true;
-        version = 2;
-        theme = pkgs.nixos-grub2-theme;
-        splashImage = ./boot_pictures/gnu.png;
-        efiSupport = true;
-        device = "nodev"; # only for efi
-      };
-      efi = {
-        canTouchEfiVariables = true;
-        efiSysMountPoint = "/boot";
-      };
-    };
-  };
-}