about summary refs log tree commit diff stats
path: root/home-manager/config/lf/commands/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/config/lf/commands/default.nix')
-rw-r--r--home-manager/config/lf/commands/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/home-manager/config/lf/commands/default.nix b/home-manager/config/lf/commands/default.nix
index 27bf01db..a7cb2039 100644
--- a/home-manager/config/lf/commands/default.nix
+++ b/home-manager/config/lf/commands/default.nix
@@ -147,13 +147,21 @@ in {
     file = ./scripts/mk_ln;
     dependencies = [];
   };
-  mk_scr = shell {
-    file = ./scripts/mk_scr;
+  mk_scr_default = shell {
+    file = ./scripts/mk_scr_default;
     dependencies = builtins.attrValues {inherit (pkgs) neovim;};
     replacementStrings = {
       SHELL_LIBRARY_TEMPLATE = "${shell_library.rawTemplate."${system}"}";
     };
   };
+  mk_scr_temp = shell {
+    file = ./scripts/mk_scr_temp;
+    dependencies = builtins.attrValues {inherit (pkgs) neovim;};
+    replacementStrings = {
+      SHELL_LIBRARY_TEMPLATE = "${shell_library.rawTemplate."${system}"}";
+      TO_BE_SHELL_LIBRARY_PATH = "%SHELL_LIBRARY_PATH"; # replacement is not recursive
+    };
+  };
   open = shell {
     file = ./scripts/open;
     dependencies = builtins.attrValues {inherit (pkgs) file xdg-utils neovim git;};