about summary refs log tree commit diff stats
path: root/hm/soispha/conf/unison/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/unison/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/hm/soispha/conf/unison/default.nix b/hm/soispha/conf/unison/default.nix
index 94824fc9..7b91920c 100644
--- a/hm/soispha/conf/unison/default.nix
+++ b/hm/soispha/conf/unison/default.nix
@@ -134,8 +134,13 @@ in {
     (sysLib.writeShellScript {
       name = "unison-sync";
       src = builtins.toFile "unison-backup" (''
-          #!/usr/bin/env sh
+          #!/usr/bin/env dash
+
+          # shellcheck source=/dev/null
+          SHELL_LIBRARY_VERSION="2.1.1" . %SHELL_LIBRARY_PATH
+
           export UNISON=${esa unisonPath};
+
           if [ "$1" = "links" ]; then
             EXTRA_OPTIONS="-links=true";
           fi