about summary refs log tree commit diff stats
path: root/hm/soispha/conf/firefox/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/firefox/default.nix')
-rw-r--r--hm/soispha/conf/firefox/default.nix29
1 files changed, 16 insertions, 13 deletions
diff --git a/hm/soispha/conf/firefox/default.nix b/hm/soispha/conf/firefox/default.nix
index 1f3b7062..d35b7256 100644
--- a/hm/soispha/conf/firefox/default.nix
+++ b/hm/soispha/conf/firefox/default.nix
@@ -22,6 +22,20 @@
 
   video-pauser = (import ./functions/extensions/video-pauser.nix) {inherit pkgs video_pause;};
 
+  profiles = {
+    "default" = {
+      inherit extensions search extraConfig bookmarks userChrome;
+      isDefault = true;
+      id = 0;
+      name = "default";
+    };
+    "clean" = {
+      isDefault = false;
+      id = 1;
+      name = "clean";
+    };
+  };
+
   taskwarriorProfiles = import ../taskwarrior/firefox {
     inherit
       extensions
@@ -32,6 +46,7 @@
       lib
       config
       ;
+    profile_size = builtins.length (builtins.attrNames profiles);
   };
 
   search = {
@@ -72,19 +87,7 @@ in {
       };
     };
     profiles =
-      {
-        "default" = {
-          inherit extensions search extraConfig bookmarks userChrome;
-          isDefault = true;
-          id = 0;
-          name = "default";
-        };
-        "clean" = {
-          isDefault = false;
-          id = 1;
-          name = "clean";
-        };
-      }
+      profiles
       // taskwarriorProfiles;
   };
 }