about summary refs log tree commit diff stats
path: root/hm/soispha/conf/firefox/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/firefox/default.nix33
1 files changed, 20 insertions, 13 deletions
diff --git a/hm/soispha/conf/firefox/default.nix b/hm/soispha/conf/firefox/default.nix
index 1040ed0b..90347de9 100644
--- a/hm/soispha/conf/firefox/default.nix
+++ b/hm/soispha/conf/firefox/default.nix
@@ -49,23 +49,30 @@ in {
         enableTridactylNative = true;
       };
     };
-    profiles."default" = {
-      inherit extensions;
-      isDefault = true;
-      id = 0;
-      name = "default";
+    profiles = {
+      "default" = {
+        inherit extensions;
+        isDefault = true;
+        id = 0;
+        name = "default";
 
-      inherit userChrome;
+        inherit userChrome;
 
-      search = {
-        default = "Brave Search";
-        force = true;
+        search = {
+          default = "Brave Search";
+          force = true;
 
-        inherit engines;
-      };
+          inherit engines;
+        };
 
-      bookmarks = [];
-      extraConfig = builtins.readFile "${user_js_nix}/user.js";
+        bookmarks = [];
+        extraConfig = builtins.readFile "${user_js_nix}/user.js";
+      };
+      "clean" = {
+        isDefault = false;
+        id = 1;
+        name = "clean";
+      };
     };
   };
 }