about summary refs log tree commit diff stats
path: root/hm/soispha/conf/firefox/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/firefox/default.nix59
1 files changed, 35 insertions, 24 deletions
diff --git a/hm/soispha/conf/firefox/default.nix b/hm/soispha/conf/firefox/default.nix
index 90347de9..567c0676 100644
--- a/hm/soispha/conf/firefox/default.nix
+++ b/hm/soispha/conf/firefox/default.nix
@@ -21,6 +21,27 @@
   buildFirefoxXpiAddon = (import ./functions/extensions) {inherit pkgs;};
 
   video-pauser = (import ./functions/extensions/video-pauser.nix) {inherit pkgs video_pause;};
+
+  taskwarriorProfiles = import ../taskwarrior/firefox {
+    inherit
+      extensions
+      userChrome
+      extraConfig
+      bookmarks
+      search
+      lib
+      ;
+  };
+
+  search = {
+    default = "Brave Search";
+    force = true;
+
+    inherit engines;
+  };
+
+  bookmarks = [];
+  extraConfig = builtins.readFile "${user_js_nix}/user.js";
 in {
   home.packages = [
     pkgs.tridactyl-native
@@ -49,30 +70,20 @@ in {
         enableTridactylNative = true;
       };
     };
-    profiles = {
-      "default" = {
-        inherit extensions;
-        isDefault = true;
-        id = 0;
-        name = "default";
-
-        inherit userChrome;
-
-        search = {
-          default = "Brave Search";
-          force = true;
-
-          inherit engines;
+    profiles =
+      {
+        "default" = {
+          inherit extensions search extraConfig bookmarks userChrome;
+          isDefault = true;
+          id = 0;
+          name = "default";
         };
-
-        bookmarks = [];
-        extraConfig = builtins.readFile "${user_js_nix}/user.js";
-      };
-      "clean" = {
-        isDefault = false;
-        id = 1;
-        name = "clean";
-      };
-    };
+        "clean" = {
+          isDefault = false;
+          id = 1;
+          name = "clean";
+        };
+      }
+      // taskwarriorProfiles;
   };
 }